
<!doctype html>
<html lang="en">
<head>
<meta charset="utf-8"><script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
<meta name="description" content="">
<meta name="author" content="">
<title>Bay Area legislators call for Senate to pass stimulus bill | News | Mountain View Online |</title>

<script type='text/javascript'>var _sf_startpt=(new Date()).getTime()</script>

<meta name="description" content="A group of Bay Area federal legislators on Wednesday called on the U.S. Senate to pass a House-approved COVID-19 stimulus bill that includes relief funding for state and local governments.">
<meta name="author" content="Bay City News Service">
<meta property="fb:app_id" content="116940531660156" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@mvvoice" />
<meta property="og:url" content="https://mv-voice.com/news/2020/08/06/bay-area-legislators-call-for-senate-to-pass-stimulus-bill" />
<meta property="og:title" content="Bay Area legislators call for Senate to pass stimulus bill" />
<meta property="og:description" content="A group of Bay Area federal legislators on Wednesday called on the U.S. Senate to pass a House-approved COVID-19 stimulus bill that includes relief funding for state and local governments." />
<meta property="og:type" content="article" />
<meta property="og:image" content="https://mv-voice.com/news/photos/2020/august/6/25131_col.jpg" />
<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>
<link media="screen" rel="stylesheet" href="//www.embarcaderopublishing.com/colorbox/colorbox.css?v=8" />
<script type="text/javascript" src="//www.embarcaderopublishing.com/colorbox/jquery.colorbox.js"></script>
<script type="text/javascript" src="//www.embarcaderopublishing.com/class/ajax.js?v=8"></script>
<script type="text/javascript" src="//www.embarcaderopublishing.com/js/hide_slide.js?v=8"></script>
<script type="text/javascript" src="//www.embarcaderopublishing.com/js/cookie.js?v=8"></script>
<script type="text/javascript" src="//www.embarcaderopublishing.com/js/login_scripts.js?v=8"></script>
<script type="application/javascript">
	function retry(isDone, next) {
		var current_trial = 0, max_retry = 50, interval = 10, is_timeout = false;
		var id = window.setInterval(
			function() {
				if (isDone()) {
					window.clearInterval(id);
					next(is_timeout);
				}
				if (current_trial++ > max_retry) {
					window.clearInterval(id);
					is_timeout = true;
					next(is_timeout);
				}
			},
			10
		);
	}

	function isIE10OrLater(user_agent) {
		var ua = user_agent.toLowerCase();
		if (ua.indexOf('msie') === 0 && ua.indexOf('trident') === 0) {
			return false;
		}
		var match = /(?:msie|rv:|Edge)[\s|\/]?([\d\.]+)/.exec(ua); // detect Project Spartan too
		if (match && parseInt(match[1], 10) >= 10) {
			return true;
		}
		return false;
	}

	function detectPrivateMode(callback) {
		var is_private;

		if (window.webkitRequestFileSystem) {
			window.webkitRequestFileSystem(
				window.TEMPORARY, 1,
				function() {
					is_private = false;
				},
				function(e) {
					console.log(e);
					is_private = true;
				}
			);
		} else if (window.indexedDB && /Firefox/.test(window.navigator.userAgent)) {
			var db;
			try {
				db = window.indexedDB.open('test');
			} catch(e) {
				is_private = true;
			}

			if (typeof is_private === 'undefined') {
				retry(
					function isDone() {
						return db.readyState === 'done' ? true : false;
					},
					function next(is_timeout) {
						if (!is_timeout) {
							is_private = db.result ? false : true;
						}
					}
				);
			}
		} else if (isIE10OrLater(window.navigator.userAgent)) {
			is_private = false;
			try {
				if (!window.indexedDB) {
					is_private = true;
				}                 
			} catch (e) {
				is_private = true;
			}
		} else if (window.localStorage && /Safari/.test(window.navigator.userAgent)) {
			try {
				window.localStorage.setItem('test', 1);
			} catch(e) {
				is_private = true;
			}

			if (typeof is_private === 'undefined') {
				is_private = false;
				window.localStorage.removeItem('test');
			}
		}

		retry(
			function isDone() {
				return typeof is_private !== 'undefined' ? true : false;
			},
			function next(is_timeout) {
				callback(is_private);
			}
		);
	}
</script>

<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-440011-7']);

  // set custom variables
  
  _gaq.push(['_trackPageview']);
_gaq.push(['_setCustomVar',
								      2,             // This custom var is set to slot #1.  Required parameter.
								      'User Type',   // The name of the custom variable.  Required parameter.
								      'Visitor',      // Sets the value of "User Type" to "Subscriber", "User" or "Visitor" depending on status.  Required parameter.
								       1             // Sets the scope to session-level.  Optional parameter.
								   ]);
						_gaq.push(['_setCustomVar',
								      3,             // This custom var is set to slot #1.  Required parameter.
								      'Unlocked',   // The name of the custom variable.  Required parameter.
								      'Viewed',      // Sets the value of "Unlocked" to "Viewed" or "Blocked" depending on status.  Required parameter.
								       1             // Sets the scope to session-level.  Optional parameter.
								   ]);
						_gaq.push(['_setCustomVar',
								      4,             // This custom var is set to slot #1.  Required parameter.
								      'Meter Count',   // The name of the custom variable.  Required parameter.
								      '0',      // Sets the value of "Unlocked" to "Viewed", "Blocked" or depending on status.  Required parameter.
								       1             // Sets the scope to session-level.  Optional parameter.
								   ]);
  (function() {
    detectPrivateMode(
        function(is_private) {
            typeof is_private === 'undefined' ? 
								_gaq.push(['_setCustomVar',
					  5,             // This custom var is set to slot #5.  Required parameter.
					  'hiding',   // The name of the custom variable.  Required parameter.
					  'unknown',      // Sets the value of Required parameter.
					   1             // Sets the scope to session-level.  Optional parameter.
				   ])
			 : is_private ? 
				_gaq.push(['_setCustomVar',
					  5,             // This custom var is set to slot #5.  Required parameter.
					  'hiding',   // The name of the custom variable.  Required parameter.
					  'private',      // Sets the value of Required parameter.
					   1             // Sets the scope to session-level.  Optional parameter.
				   ])
			 : 
				_gaq.push(['_setCustomVar',
					  5,             // This custom var is set to slot #5.  Required parameter.
					  'hiding',   // The name of the custom variable.  Required parameter.
					  'not private',      // Sets the value of Required parameter.
					   1             // Sets the scope to session-level.  Optional parameter.
				   ])
		}
    );
  })();
	
  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    //ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
	ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();



//Evil Robot Detection -- Added by FAB 6/6/2012
// http://stkywll.com/2012/04/27/annoying-robots-a-solution-for-google-analytics/

	var category = 'trafficQuality';
	var dimension = 'botDetection';
	var human_events = ['onkeydown','onmousemove'];

	if ( navigator.appName == 'Microsoft Internet Explorer' && !document.referrer) {
		for(var i = 0; i < human_events.length; i++){
			document.attachEvent(human_events[i], ourEventPushOnce);
		}
	}else{
		_gaq.push( [ '_trackEvent', category, dimension, 'botExcluded', 1, true ] );
	}

	function ourEventPushOnce(ev) {

		_gaq.push( [ '_trackEvent', category, dimension, 'on' + ev.type, 1, true ] );

		for(var i = 0; i < human_events.length; i++){
			document.detachEvent(human_events[i], ourEventPushOnce);
		}

	} // end ourEventPushOnce()

	//End Evil Robot Detection

</script>


<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '1381337412046565');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=1381337412046565&ev=PageView&noscript=1"
/></noscript>
 <script type="text/javascript">
	var email = document.cookie;
    if (sessionStorage.getItem("c_messaging") == null || email.includes("embarcaderopublishing.com"))
	{
		//skip after setting a value
		sessionStorage.setItem('c_messaging', 'y');
        //alert("Hello! I am just starting!!");
	}
	else if (sessionStorage.getItem("c_messaging") == 'x' || email.includes("embarcaderopublishing.com"))
	{
		//skip
        //alert("Hello! I am an X box!!");
    }
	else
    {
		sessionStorage.setItem('c_messaging', 'x');
		setTimeout(c_messaging,20000);
		
		function c_messaging()
		{
			$.colorbox(
			{
				close:"X",
				opacity:0.3,
				overlayClose:false,
				href:"/user/subscribe/c_messaging.pop.php"
			});
		}
	}
	</script>

<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
                        var gptadslots = [];
                        var googletag = googletag || {
                            cmd: []
                        };
                    </script>
<script>

                      googletag.cmd.push(function() {
                      
                      
                        var mappingsizes = googletag.sizeMapping().
                        addSize([992, 0], [[970, 250], [1, 1]]).
                        addSize([768, 0], [[728, 90], [1, 1]]).
                        addSize([320, 0], [[320, 50], [320, 100], [320, 150]]).
                        addSize([0, 0], [[320, 50], [1, 1]]).

                        build();


                        //Adslot declaration
                      
                        googletag.defineSlot('/1006587/mountainview_news_responsive_1', [[320, 50], [728, 90], [970, 250]], 'div-gpt-ad-mountainview_news_responsive_1').defineSizeMapping(mappingsizes).addService(googletag.pubads()); 
                        googletag.defineSlot('/1006587/mountainview_news_responsive_2', [[320, 50], [728, 90], [970, 250]], 'div-gpt-ad-mountainview_news_responsive_2').defineSizeMapping(mappingsizes).addService(googletag.pubads()); 
                        
                        googletag.defineSlot('/1006587/mountainview_news_story_300x250_1', [300, 250], 'div-gpt-ad-mountainview_news_story_300x250_1').addService(googletag.pubads());
                        googletag.defineSlot('/1006587/mountainview_news_story_300x250_2', [300, 250], 'div-gpt-ad-mountainview_news_story_300x250_2').addService(googletag.pubads());
                        googletag.defineSlot('/1006587/mountainview_news_story_300x250_3', [300, 250], 'div-gpt-ad-mountainview_news_story_300x250_3').addService(googletag.pubads());
                        googletag.defineSlot('/1006587/mountainview_news_story_300x250_4', [300, 250], 'div-gpt-ad-mountainview_news_story_300x250_4').addService(googletag.pubads());

                        
                        googletag.pubads().enableSingleRequest();
                        googletag.pubads().collapseEmptyDivs();
                        googletag.enableServices();
                      });
                    </script>

<script src="//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>

<link rel="stylesheet" href="/twitter_bootstrap/4.3.1/css/bootstrap.min.css">
<script type="text/javascript" src="//www.embarcaderopublishing.com/js/jquery.js"></script>
<link rel="stylesheet" type="text/css" href="//www.embarcaderopublishing.com/css/styles_responsive.css?v=8" />
<link media="screen" rel="stylesheet" href="//www.embarcaderopublishing.com/colorbox/colorbox.css?v=8" />
<script type="text/javascript" src="//www.embarcaderopublishing.com/colorbox/jquery.colorbox.js"></script>
<script type="text/javascript" src="//www.embarcaderopublishing.com/js/login_scripts.js?v=8"></script>
<script src="https://kit.fontawesome.com/20c4b40556.js" crossorigin="anonymous"></script>
<script type="text/javascript">
        $(document).ready(function(){

            $(window).scroll(function(){
                if ($(this).scrollTop() > 100) {
                    $('.scrollup').fadeIn();
                    $('.scrolldn').fadeIn();
                } else {
                    $('.scrollup').fadeOut();
                    $('.scrolldn').fadeOut();
                }
            });

            $('.scrollup').click(function(){
                $("html, body").animate({ scrollTop: 0 }, 1000);
                return false;
            });

            $('.scrolldn').click(function(){
                $("html, body").animate({ scrollTop: $(document).height() }, 1000);
                return false;
            });
        });
    </script>
</head>
<body>
<header>

<nav class="navbar navbar-light fixed-top">
<a class="navbar-brand" href="/"><img src="/art/top_logo.png"></a>

<button class="navbar-toggler order-first" type="button" data-toggle="collapse" data-target="#navbarCollapse" aria-controls="navbarCollapse" aria-expanded="false" aria-label="Toggle navigation">
<span class="navbar-toggler-icon"></span>
</button>
<div align="right" ;>
<span class="display-desktop">
<a href="javascript:em_login_link()" class="btn btn-success btn-sm">
Login
</a>
</span>
<span class="display-mobile">
<a href="javascript:em_login_link()"><i class="fas fa-sign-in-alt fa-lg"></i></a>
</span>
&nbsp;
<a href="/user/subscribe/" class="btn btn-info btn-sm btn-join">
Join
</a>
<span class="display-desktop">
&nbsp; <a data-toggle="collapse" href="#Search" aria-expanded="false" aria-controls="Search"><i class="fas fa-search"></i></a>
</span>
</div>
<div class="collapse navbar-collapse" id="navbarCollapse">
<ul class="navbar-nav mr-auto">
<li class="nav-item active">
<a class="nav-link" href="/">Home</a>
</li>
<li class="nav-item">
<a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">News</a>
<div class="dropdown-menu" aria-labelledby="navbarDropdownMenuLink">
<a class="dropdown-item" href="/news/">Top Stories</a>
<a class="dropdown-item" href="/news/recent_headlines.php">Recent News</a>
<a class="dropdown-item" href="/news/section/editorials/">Editorials</a>
<a class="dropdown-item" href="/obituaries/">Obituaries</a>
<a class="dropdown-item" href="/calmatters/">State News from CALmatters</a>
<a class="dropdown-item" href="/best_of/">Best Of</a>
</div>
</li>
<li class="nav-item">
<a class="nav-link" href="/square/">Town Square</a>
</li>
<li class="nav-item">
<a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">Blogs</a>
<div class="dropdown-menu" aria-labelledby="navbarDropdownMenuLink">
<a class="dropdown-item" href="/blogs/">Meet our Bloggers</a>
<a class="dropdown-item" href="/blogs/recent/">Most Recent Posts</a>
</div>
</li>
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
A&amp;E
</a>
<div class="dropdown-menu" aria-labelledby="navbarDropdownMenuLink">
<a class="dropdown-item" href="/arts/">Features and Reviews</a>
<a class="dropdown-item" href="/calendar/">Calendar</a>
<a class="dropdown-item" href="/movies/">Movies</a>
<a class="dropdown-item" href="/best_of">Readers' Choice</a>
<a class="dropdown-item" href="https://www.destinationpaloalto.com/eating-and-nightlife" target="_blank">Restaurants</a>
</div>
</li>
<li class="nav-item">
<a class="nav-link" href="/real_estate/">Real Estate</a>
</li>
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
Print Edition
</a>
<div class="dropdown-menu" aria-labelledby="navbarDropdownMenuLink">
<a class="dropdown-item" href="/print/">Current Edition</a>
<a class="dropdown-item" href="/print/editions/">Archives</a>
<a class="dropdown-item" href="/print/special/">Special Publications</a>
<a class="dropdown-item" href="/promotions/">Promotions &amp; Contests</a>
</div>
</li>
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
Join
</a>
<div class="dropdown-menu" aria-labelledby="navbarDropdownMenuLink">
<a class="dropdown-item" href="/user/subscribe/">Become a Subscribing Member</a>
<a class="dropdown-item" href="/express/">Express Newsletters</a>
<a class="dropdown-item" href="/promotions/">Promotions &amp; Contests</a>
</div>
</li>
<li class="nav-item dropdown">
<a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMenuLink" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
Contact
</a>
<div class="dropdown-menu" aria-labelledby="navbarDropdownMenuLink">
<a class="dropdown-item" href="/about/contact/">Contact Info</a>
<a class="dropdown-item" href="/about/contact/mailto.php?e=editor&s=newstip">Submit News Tip/Photo</a>
<a class="dropdown-item" href="https://portal.cityspark.com/EventEntry/EventEntry/MountainViewVoice/" target="_blank">Submit Calendar Item</a>
<a class="dropdown-item" href="/circulation/">Delivery &amp; Subscription Services</a>
</div>
</li>
<li class="nav-item">
<a class="nav-link" href="/search/">Search</a>
</li>
<li class="nav-item">
<a class="nav-link" href="/user/register/" target="_blank">Register</a>
</li>
<li class="nav-item">
<a class="nav-link" href="javascript:em_login_link()">Login</a>
</li>
</ul>
</div>
</nav>
</header>
<div class="mt60"></div>
<div class="row">
<div class="col">
<div class="collapse multi-collapse" id="Search">
<form action="/search" id="cse-search-box" class="container d-print-none" style="padding-top: 20px;">
<div class="form-group">
<div class="input-group">
<div class="input-group-prepend">
<div class="input-group-text">
<i class="fa fa-search"></i>
</div>
</div>
<input type="hidden" name="cx" value="partner-pub-2203864489454098:hd30o9u6s71" />
<input type="hidden" name="cof" value="FORID:10" />
<input type="hidden" name="ie" value="UTF-8" />
<input id="q" name="q" placeholder="Search" type="text" class="form-control">
</div>
</div>
<div class="form-group" align="right">
<button name="submit" type="submit" class="btn btn-sm btn-success">Search</button>
</div>
</form>
</div>
</div>
</div>


<div class="outline-me ad-break-top d-print-none" id="ad-block-00">
<div id="div-gpt-ad-mountainview_news_responsive_1">
<script>
                googletag.cmd.push(function() {
                    googletag.display("div-gpt-ad-mountainview_news_responsive_1");
                });
                </script>
</div>
</div>
<div class="container d-print-none">
<div class="row h-100">
<div class="col-md-8 offset-md-2 outline-me content-block" id="block-01">
<div class="text-block">
<p class="section">News <span class="display-mobile">
<a data-toggle="collapse" href="#Search" aria-expanded="false" aria-controls="Search" style="float: right;"><i class="fas fa-search"></i></a>
</span>
</p>
<h1>Bay Area legislators call for Senate to pass stimulus bill</h1>
<h2>Rep. Anna Eshoo: 'The health of our democracy is just as important as the health' of its constituents</h2>
<div class="share-tools">
<div class="addthis_inline_share_toolbox"></div>
</div>
<p class="byline">by <a href="/about/contact/mailto.php?e=" target="_blank" class="byline">Bay City News Service</a>
</p>
<p class="dateline">Uploaded: Thu, Aug 6, 2020, 1:31 pm
<span style="float: right;">
<i class="fas fa-comments"></i> 2
 </span>
<br>
Time to read: about 2 minutes
</p>
</div>
</div>
<div class="col-md-2 outline-me">
</div>
</div>
</div>
<div class="container d-print-none">
<div class="row h-100">
<div class="col-md-8 offset-md-2 outline-me content-block" id="block-01">
<div class="text-block">
<div class="inline-100-photo d-print-none">
<img src="/news/photos/2020/august/6/25131_col.jpg" class="img-fluid">
<p class="caption">At a virtual briefing on Aug. 5, Rep. Anna Eshoo, D-Palo Alto, argued that funding for the Postal Service is of similar importance to extending unemployment benefits. Embarcadero Media file photo by Sadie Stinson.</p>
</div>
<p>A group of Bay Area federal legislators on Wednesday called on the U.S. Senate to pass a House-approved COVID-19 stimulus bill that includes relief funding for state and local governments and extends the distribution of enhanced federal unemployment benefits.</p>
<p>Reps. Mike Thompson, D-St. Helena, Anna Eshoo, D-Palo Alto, and Jerry McNerney, D-Antioch, held a virtual briefing Wednesday to demand an extension of the $600 per week in expanded unemployment benefits that was included in the first coronavirus relief bill in late March.</p>
<p>The benefits expired last Friday, something Thompson laid at the feet of Senate Republicans and Senate Majority Leader Mitch McConnell.</p>
<p>"Senate Republicans went home last Friday and they let these benefits expire," Thompson said. "Too many people in my district are dependent on these benefits to get by."</p>
<p>Some 30 million people in the U.S. have relied on the expanded unemployment insurance included in the Coronavirus Aid, Relief, and Economic Security (CARES) Act. According to the group of legislators, that includes roughly 3.2 million Californians.</p>
</div>
</div>
<div class="col-md-2 outline-me my-auto side-block d-print-none" id="side-block-01">
<p class="side-block-headline">What's local journalism worth to you?</p>
<p class="side-block-text">Support Mountain View Online for as little as $5/month.</p>
<a href="/user/subscribe/?utm_source=internal&utm_medium=story_page&utm_campaign=join" class="btn btn-info btn-sm btn-block">Learn more</a>
</div> </div>
</div>
<div class="outline-me ad-break d-print-none" id="ad-block-01">
<div class="container">
<div class="row">
<div class="col-md-8 offset-md-2 ad-content" id="block-03">
<div class="row">
<div class="col-lg-6 ad-break-first-medium-rectangle">
<div id="div-gpt-ad-mountainview_news_story_300x250_1">
<script>
                                            googletag.cmd.push(function() {
                                                googletag.display("div-gpt-ad-mountainview_news_story_300x250_1");
                                            });
                                            </script>
</div>
</div>
<div class="col-lg-6">
<div id="div-gpt-ad-mountainview_news_story_300x250_2">
<script>
                                            googletag.cmd.push(function() {
                                                googletag.display("div-gpt-ad-mountainview_news_story_300x250_2");
                                            });
                                            </script>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container d-print-none">
<div class="row h-100">
<div class="col-md-8 offset-md-2 outline-me content-block" id="block-02">
<div class="text-block">
<p>The House's coronavirus relief bill -- the Health and Economic Recovery Omnibus Emergency Solutions (HEROES) Act -- extends federal unemployment benefits for those who have lost their job due to the pandemic as well as funding for state and local governments teetering on insolvency and the U.S. Postal Service.</p>
<p>McConnell and negotiators in the Trump Administration have balked at extending the temporary $600 per week payments, opting instead of payments of around $200 per week.</p>
<p>U.S. Treasury Secretary Steve Mnuchin suggested on Sunday that the benefits disincentivized people to return to the workplace and, in some cases, amounted to more than people were making when they were employed.</p>
<p>Thompson threw cold water on Mnuchin's argument, citing studies from Yale University and the Brookings Institution that found scant evidence of unemployment benefits disincentivizing peoples' search for work.</p>
<p>McNerney suggested the cut in benefits would force his constituents and people across the country to choose between paying rent and paying for essentials like food and medical care.</p>
</div>
</div>
<div class="col-md-2 outline-me my-auto side-block d-print-none" id="side-block-02">
<p class="side-block-headline">Stay informed</p>
<p class="side-block-text">Get daily headlines sent straight to your inbox.</p>
<a href="/express/?utm_source=internal&utm_medium=story_page&utm_campaign=express" class="btn btn-info btn-sm btn-block">Sign up</a>
</div> </div>
</div>
<div class="outline-me ad-break d-print-none" id="ad-block-02">
<div id="div-gpt-ad-mountainview_news_responsive_2">
<script>
                googletag.cmd.push(function() {
                    googletag.display("div-gpt-ad-mountainview_news_responsive_2");
                });
                </script>
</div>
</div>
<div class="container d-print-none">
<div class="row h-100">
<div class="col-md-8 offset-md-2 outline-me content-block" id="block-03">
<div class="text-block">
<p>"It's asking some to choose between the needs of their children and the needs of their parents, of whom are completely dependent upon them," he said.</p>
<p>Thompson and McNerney argued that House Democrats have already made their offer and Senate Republicans haven't negotiated in good conscience.</p>
<p>"The Senate needs to put something on the table that we can work with," McNerney said.</p>
<p>Eshoo argued that supportive funding for the Postal Service is of similar importance to extending unemployment benefits as the country lurches closer to a general election that is likely to generate a surge of mail-in voting during the pandemic.</p>
<p>Postal Service officials have warned federal legislators that the agency will be bankrupt by September if it does not receive federal aid.</p>
</div>
</div>
<div class="col-md-2 outline-me my-auto side-block side-block-mobile-full d-print-none" id="side-block-03">
<div class="d-none d-md-block">
<p class="side-block-headline">Most Viewed Stories</p>
<p class="side-block-text side-block-hanging-indent">&#9632; <a href="/news/2020/08/05/albuquerque-man-pleads-guilty-to-sexual-assault-in-2004-mountain-view-case">Albuquerque man pleads guilty to sexual assault in 2004 Mountain View case</a></p>
<p class="side-block-text side-block-hanging-indent">&#9632; <a href="/news/2020/08/04/supervisor-federal-relief-mediation-needed-to-avoid-large-scale-evictions-in-santa-clara-county">Supervisor: Federal relief, mediation needed to avoid large scale evictions in Santa Clara County</a></p>
<p class="side-block-text side-block-hanging-indent">&#9632; <a href="/news/2020/08/04/caltrain-gets-a-lifeline-after-counties-strike-compromise-on-tax-measure">Caltrain gets a lifeline after counties strike compromise on tax measure</a></p>
<p class="side-block-text side-block-hanging-indent">&#9632; <a href="/news/2020/08/04/despite-looming-deficit-santa-clara-county-supervisors-reject-sales-tax-hike-for-the-november-ballot">Despite looming deficit, Santa Clara County supervisors reject sales tax hike for the November ballot</a></p>
<p class="side-block-text side-block-hanging-indent">&#9632; <a href="/news/2020/08/04/palo-alto-moves-to-expand-access-to-residents-only-foothills-park">Palo Alto moves to expand access to 'residents-only' Foothills Park</a></p>
</div>
<div class="d-sm-block d-md-none">
<p class="side-block-headline">Most Viewed Stories</p>
<div class="row">
<div class="col-6">
<p class="side-block-text side-block-hanging-indent">&#9632; <a href="/news/2020/08/05/albuquerque-man-pleads-guilty-to-sexual-assault-in-2004-mountain-view-case">Albuquerque man pleads guilty to sexual assault in 2004 Mountain View case</a></p>
</div>
<div class="col-6">
<p class="side-block-text side-block-hanging-indent">&#9632; <a href="/news/2020/08/04/supervisor-federal-relief-mediation-needed-to-avoid-large-scale-evictions-in-santa-clara-county">Supervisor: Federal relief, mediation needed to avoid large scale evictions in Santa Clara County</a></p>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="outline-me ad-break d-print-none" id="ad-block-04">
<div class="container">
<div class="row">
<div class="col-md-8 offset-md-2" id="block-04">
<div class="row">
<div class="col-lg-6 ad-break-first-medium-rectangle">
<div id="div-gpt-ad-mountainview_news_story_300x250_3">
<script>
                                    googletag.cmd.push(function() {
                                        googletag.display("div-gpt-ad-mountainview_news_story_300x250_3");
                                    });
                                    </script>
</div>
</div>
<div class="col-lg-6">
<div id="div-gpt-ad-mountainview_news_story_300x250_4">
<script>
                                    googletag.cmd.push(function() {
                                        googletag.display("div-gpt-ad-mountainview_news_story_300x250_4");
                                    });
                                    </script>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container d-print-none">
<div class="row h-100">
<div class="col-md-8 offset-md-2 outline-me content-block" id="block-04">
<div class="text-block">
<p>"The health of our democracy is just as important as the health" of its constituents, Eshoo said.</p>
<p>McNerney argued that every day the Senate does not negotiate in good faith over the next coronavirus relief bill is another day that they're failing to support the American people.</p>
<p>"I've seen a desperation in my district and I'm sure it's going to get worse," he said. "We need to act now."</p>
<p><span style="font-style:italic;font-weight:bold;">Find comprehensive coverage on the Midpeninsula's response to the new coronavirus by Palo Alto Online, the Mountain View Voice and the Almanac</span> <a href="https://wke.lt/w/s/JHtUCe"><span style="font-style:italic;font-weight:bold;">here</span></a>.</p>
</div>
</div>
<div class="col-md-2 outline-me my-auto side-block d-print-none" id="side-block-04">
<p class="side-block-headline">Craving a new voice in Peninsula dining?</p>
<p class="side-block-text">Sign up for the Peninsula Foodist newsletter.</p>
<a href="/express/foodist/?utm_source=internal&utm_medium=story_page&utm_campaign=foodist" class="btn btn-info btn-sm btn-block btn-custom">Sign up now</a>
</div> </div>
</div>
<div class="container d-print-none">
<div class="row h-100">
<div class="col-md-8 offset-md-2 outline-me content-block" id="block-tag">
<div class="text-block">
<p class="tag">
Follow Mountain View Voice Online on Twitter <a href="//twitter.com/mvvoice" target="_blank" title="Twitter">@mvvoice</a>, <a href="//facebook.com/MountainViewVoice" target="_blank" title="Facebook">Facebook</a> and on Instagram <a href="//instagram.com/mvvoice" target="_blank" title="Twitter">@mvvoice</a> for breaking news, local events, photos, videos and more.
<div data-widget-id="rel_362-1"></div>
</p>
</div>
</div>
<div class="col-md-2 outline-me my-auto side-block" id="side-block-tag">
</div>
</div>
</div>
<div class="container d-none d-print-block">
<meta itemprop="pageType" content="article">
<h1 itemprop="headline">Bay Area legislators call for Senate to pass stimulus bill</h1>
<h2>Rep. Anna Eshoo: 'The health of our democracy is just as important as the health' of its constituents</h2>
<meta itemprop="author" content="Bay City News Service">
<p class="byline">by <a href="/about/contact/mailto.php?e=" target="_blank" class="byline">Bay City News Service</a> / </p>
<meta itemprop="datePublished" content="2020-08-06T13:31:00-07:00">
<p class="dateline">Uploaded: Thu, Aug 6, 2020, 1:31 pm<br>
<meta itemprop="thumbnailUrl" content="https://mv-voice.com/news/photos/2020/august/6/25131_col.jpg">
<article itemprop="articleBody"><p>A group of Bay Area federal legislators on Wednesday called on the U.S. Senate to pass a House-approved COVID-19 stimulus bill that includes relief funding for state and local governments and extends the distribution of enhanced federal unemployment benefits.</p><p>Reps. Mike Thompson, D-St. Helena, Anna Eshoo, D-Palo Alto, and Jerry McNerney, D-Antioch, held a virtual briefing Wednesday to demand an extension of the $600 per week in expanded unemployment benefits that was included in the first coronavirus relief bill in late March.</p><p>The benefits expired last Friday, something Thompson laid at the feet of Senate Republicans and Senate Majority Leader Mitch McConnell.</p><p>"Senate Republicans went home last Friday and they let these benefits expire," Thompson said. "Too many people in my district are dependent on these benefits to get by."</p><p>Some 30 million people in the U.S. have relied on the expanded unemployment insurance included in the Coronavirus Aid, Relief, and Economic Security (CARES) Act. According to the group of legislators, that includes roughly 3.2 million Californians.</p><p>The House's coronavirus relief bill -- the Health and Economic Recovery Omnibus Emergency Solutions (HEROES) Act -- extends federal unemployment benefits for those who have lost their job due to the pandemic as well as funding for state and local governments teetering on insolvency and the U.S. Postal Service.</p><p>McConnell and negotiators in the Trump Administration have balked at extending the temporary $600 per week payments, opting instead of payments of around $200 per week.</p><p>U.S. Treasury Secretary Steve Mnuchin suggested on Sunday that the benefits disincentivized people to return to the workplace and, in some cases, amounted to more than people were making when they were employed.</p><p>Thompson threw cold water on Mnuchin's argument, citing studies from Yale University and the Brookings Institution that found scant evidence of unemployment benefits disincentivizing peoples' search for work.</p><p>McNerney suggested the cut in benefits would force his constituents and people across the country to choose between paying rent and paying for essentials like food and medical care.</p><p>"It's asking some to choose between the needs of their children and the needs of their parents, of whom are completely dependent upon them," he said.</p><p>Thompson and McNerney argued that House Democrats have already made their offer and Senate Republicans haven't negotiated in good conscience.</p><p>"The Senate needs to put something on the table that we can work with," McNerney said.</p><p>Eshoo argued that supportive funding for the Postal Service is of similar importance to extending unemployment benefits as the country lurches closer to a general election that is likely to generate a surge of mail-in voting during the pandemic.</p><p>Postal Service officials have warned federal legislators that the agency will be bankrupt by September if it does not receive federal aid.</p><p>"The health of our democracy is just as important as the health" of its constituents, Eshoo said.</p><p>McNerney argued that every day the Senate does not negotiate in good faith over the next coronavirus relief bill is another day that they're failing to support the American people.</p><p>"I've seen a desperation in my district and I'm sure it's going to get worse," he said. "We need to act now."</p><p><span style="font-style:italic;font-weight:bold;">Find comprehensive coverage on the Midpeninsula's response to the new coronavirus by Palo Alto Online, the Mountain View Voice and the Almanac</span> <a href="https://wke.lt/w/s/JHtUCe"><span style="font-style:italic;font-weight:bold;">here</span></a>.</p></article>
</div>
<div class="container d-print-none">
<a name="comments"></a>
<div class="row h-100">
<div class="col-md-8 offset-md-2 outline-me comment">
<h4>Comments</h4>
<a name="comment_121662"></a>
<div class="row comment-block">
<div class="col-md-2 d-none d-md-block comment-person-block">
<strong>Steven Goldstein</strong><br>
<small> <em>Registered user</em><br>
Old Mountain View <br>
33 minutes ago</small>
</div>
<div class="col-md-2 d-sm-block d-md-none comment-person-block">
<strong>Steven Goldstein</strong>,
<small> Old Mountain View <br>
<em>Registered user</em><br>
33 minutes ago</small>
</div>
<div class="col-md-10 col-12">
<div class="card-body bg-light">
<div class="comment-like small">
 Like this comment
</div>
<p>So last week we had 167,000 new hires.<br />
<br />
We lost 1,100,000 jobs that same week.<br />
<br />
Please refer to the webpage titled " These Charts Put the Historic U.S. Job Losses in Perspective " (<a href="https://www.visualcapitalist.com/charts-historic-u-s-job-losses-perspective/">Web Link</a>)<br />
<br />
That is about twice the job losses we had in the peak period of great recession which was about 600,000 to 700,000 a week.<br />
<br />
We lost only about 2.6 million during the peak period of 4 weeks during that disaster, it took to 2016 to recover the jobs from that crisis, that was 9 years.<br />
<br />
During this crisis we lost 22,000,000 jobs in a 4 week period. If we try to recover all the jobs like the last time it will take perhaps 80-90 years.<br />
<br />
When is everyone going to wake up that this is not fixable via a STIMULUS package, We have to go on LIFE SUPPORT mode now until the COVID crisis is over, and it is better to freeze all money for the time being, thereby all businesses will not have bills to pay along with the people. That is a fair process isn't it?<br />
</p>
<div class="float-right small">
<a href="javascript:showWhy('/square/abuse.php?w=1&amp;ci=121662', 'abuse_121662')" onClick="showWhy('/square/abuse.php?w=1&amp;ci=121662', 'abuse_121662')">Report Objectionable Comment</a> &nbsp; | &nbsp;
<div id="abuse_121662" class="float-right">
<a href="/about/contact/mailto.php?e=ts_moderator" rel="nofollow" target="_blank">Email Moderator</a>
</div>
</div>
<br>
</div>
</div>
</div>
<a name="comment_121663"></a>
<div class="row comment-block">
<div class="col-md-2 d-none d-md-block comment-person-block">
<strong>Gary</strong><br>
<small> <em>Registered user</em><br>
Sylvan Park <br>
7 minutes ago</small>
</div>
<div class="col-md-2 d-sm-block d-md-none comment-person-block">
<strong>Gary</strong>,
<small> Sylvan Park <br>
<em>Registered user</em><br>
7 minutes ago</small>
</div>
<div class="col-md-10 col-12">
<div class="card-body bg-light">
<div class="comment-like small">
2 people like this
</div>
<p>There can seemingly never be a stimulus unless the very rich get much of the money. Plus, now relief is up against the Trump-Putin re-election campaign. For Trump to win, Americans must pretend - even to themselves - that Covid-19 is no big deal. Back to school. Back to work. Millions die. But millions in America die every year from natural causes. So Trump might even resort to calling Covid-19 "natural" unless he thinks it would be slicker to stick with the "China Virus" or the "Obama-Biden Virus." And Trump needs one other bit of help to get re-elected: a low turnout. For that, Trump will undermine and maybe even shut down the U.S. Postal Service. Get involved in the national election as if your life depends on it. It does.</p>
<div class="float-right small">
<a href="javascript:showWhy('/square/abuse.php?w=1&amp;ci=121663', 'abuse_121663')" onClick="showWhy('/square/abuse.php?w=1&amp;ci=121663', 'abuse_121663')">Report Objectionable Comment</a> &nbsp; | &nbsp;
<div id="abuse_121663" class="float-right">
<a href="/about/contact/mailto.php?e=ts_moderator" rel="nofollow" target="_blank">Email Moderator</a>
</div>
</div>
<br>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="container d-print-none">
<div class="row h-100">
<div class="col-md-8 offset-md-2 outline-me comment">
<div class="comment"></div>
<a name="comment_form" id="comment_form"></a>
<div class="row comment-block">
<div class="col-12">
<div class="card-body bg-light comment-hunter-block">
<p><strong>Don't miss out on the discussion!</strong><br>
<small>Sign up to be notified of new comments on this topic.</small></p>
<form action="/square/process.php?p=9&t=20270" method="post">
<span class="small"></span><input class="form-control" required="required" type="text" name="email" value="" placeholder="Your email address"></p>
<button type="submit" class="btn btn-sm btn-info" name="submit" value="submit">Submit</button>
</form>
</div>
</div>
</div>
<h4>Post a comment</h4>
<div><p>In order to encourage respectful and thoughtful discussion, commenting on stories is available to
those who are registered users. If you are already a registered user and the commenting form is not below,
<a href="javascript:em_login_link();">you need to log in</a>. If you are not registered, you can do so
<a href="javascript:em_sub_register();">here</a>.</p>
<p>Please make sure your comments are truthful, on-topic and do not disrespect another poster.
Don't be snarky or belittling. All postings are subject to our <a href="/about/terms_of_use/">TERMS OF USE</a>,
and may be deleted if deemed inappropriate by our staff.</p>
<p><a href="/news/2020/07/31/in-experiment-town-square-forum-commenting-will-be-limited-to-registered-users">See our announcement about requiring registration for commenting.</a></p>
</div>
</div>
<div class="col-md-2 outline-me">
</div>
</div>
</div>
<style>
@media only screen and (min-width: 767px) {
    /* don't show the mobile version on desktop */
    ._magnetRelConrel_362-1 {
        display: none;
    }
}
@media only screen and (max-width: 767px) {
    /* don't show the pop-up on mobile */
    ._magnetRelConrel_362-3 {
        display: none;
    }
}
@media only print {
    /* don't show any of these when printing  */
    ._magnetRelConrel_362-3 {
        display: none;
    }
    ._magnetRelConrel_362-1 {
        display: none;
    }
}
</style>
<meta itemprop="url" content="https://mv-voice.com/news/2020/08/06/bay-area-legislators-call-for-senate-to-pass-stimulus-bill">
<meta itemprop="inLanguage" content="en">
<meta itemprop="identifier" content="16668">
<script type="text/javascript">
    (function() { 
    var ms = document.createElement('script'); ms.type = 'text/javascript'; ms.async = true; 
    ms.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') + '//magnetapi.klangoo.com/w/Widgets_362.js'; 
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ms, s);
    })();
</script>
<div data-widget-id="rel_362-3"></div>
<a class="scrolldn" href="#"></a>
<a class="scrollup" href="#"></a>
<footer class="footer small">
<div class="d-print-none">
<div class="container outline-me d-none d-md-block">
<div class="row">
<div class="col-md-12">
<h5>Index</h5>
</div>
<div class="col-md-3">
<p><a href="/">Home</a><br>
<a href="/news">News</a><br>
<a href="/square">TownSquare</a><br>
<a href="/blogs/">Blogs</a><br>
<a href="/arts">A&amp;E</a><br>
<a href="/real_estate">Home &amp; Real Estate</a><br>
<a href="/obituaries">Obituaries</a></p>
</div>
<div class="col-md-3">
<p><a href="/about/contact/mailto.php?e=editor&s=newstip">Send News Tips</a><br>
<a href="/user/subscribe/" target="_blank">Subscribe</a><br>
<a href="/print">Print Edition/Archives</a><br>
<a href="/express/"> Express</a> / <a href="/express/weekend/"> Weekend Express</a><br>
<a href="/print/special">Special Pubs</a><br>
<a href="/circulation">Circulation &amp; Delivery</a><br>
<a href="/promotions">Promotions</a></p>
</div>
<div class="col-md-3">
<p><a href="/about">About Us</a><br>
<a href="/about/contact">Contact Us</a><br>
<a href="https://mailchi.mp/embarcaderomediagroup/advertise" target="_blank">Advertising Info</a><br>
<a href="/about/terms_of_use">Terms of Use</a><br>
<a href="/about/privacy_policy">Privacy Policy</a><br>
&nbsp;<br>
<a href="http://www.PaloAltoOnline.com" target="_blank">Palo Alto Online</a><br>
<a href="http://www.AlmanacNews.com" target="_blank">The Almanac</a><br>
<a href="https://www.thesixfifty.com" target="_blank">TheSixFifty.com</a></p>
</div>
<div class="col-md-3">
<p>&copy; 2020 <a href="/">Mountain View Online</a><br>
All rights reserved.<br>
&nbsp;<br>
<a href="http://www.EmbarcaderoMediaGroup.com" target="_blank">Embarcadero Media</a><br>
&nbsp;<br>
<a href="/press_releases/" target="_blank">PR MediaRelease</a><br>
<a href="/emdesign/" target="_blank">Sponsored content</a><br>
<a href="/user/go_mobile.php">Mobile site</a></p>
</div>
</div>
</div>
</div>
<div class="container outline-me d-sm-block d-md-none d-print-block" style="padding-bottom: 60px;">
<p>&copy; 2020 <a href="/">Mountain View Online</a>. All rights reserved.<br>
</div>
</footer>
<script src="/twitter_bootstrap/4.3.1/js/bootstrap.min.js"></script>

<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-7apeS9pNVYMQo"
});
</script>
<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-7apeS9pNVYMQo.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>



<script type='text/javascript'>
        var _sf_async_config = _sf_async_config || {};
        /** CONFIGURATION START **/
        _sf_async_config.uid = 26708;
                _sf_async_config.domain = 'mv-voice.com';
        _sf_async_config.sections = 'News';  // This changes based on section
        _sf_async_config.authors = 'Bay City News Service';    // This changes based on author
        _cbq = window._cbq = (window._cbq || []); // added this line and next to show user type (http://support.chartbeat.com/docs/#usertype)
        _cbq.push(['_acct', 'anon']);
        /** CONFIGURATION END **/
         (function () {
              function loadChartbeat() {
                   window._sf_endpt = (new Date()).getTime();
                   var e = document.createElement('script');
                   e.setAttribute('language', 'javascript');
                   e.setAttribute('type', 'text/javascript');
                   e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
                   document.body.appendChild(e);
              }
              loadChartbeat();
         })();
    </script>


<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-59889825bf821865"></script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"4e2e5ec189","applicationID":"13429415","transactionName":"b1RQMUNVDUoDWhVeW1YeZxdYGw1cFUpOXlpcVEpLQVwT","queueTime":0,"applicationTime":52,"atts":"QxNTRwtPHkQ=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
